• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~! QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言怎么写关联文件源码

易语言怎么写关联文件源码
文件是 RACK 格式的 需要关联 D 盘的 vdsnm.exe 这个文件

源码

.版本 2
  
_ 文件关联 (“D:\vdsnm.exe”, “rack”, “D:\vdsnm.exe”)
 
.子程序 _ 文件关联
.参数 关联应用程序, 文本型, , 当双击对应的文件时就运行该应用程序打开
.参数 关联文件类型, 文本型, , 欲关联的文件类型,如“mp3”
.参数 关联文件图标, 文本型, , ICQ 文件路径或 EXE 文件路径,注销后才有效
.参数 设置默认, 逻辑型, , 是否设为默认
.如果真 (设置默认)
    删除注册项 (#现行用户, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 关联文件类型 + “\OpenWithList”)
    删除注册项 (#现行用户, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 关联文件类型 + “\OpenWithProgids”)
    删除注册项 (#现行用户, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 关联文件类型 + “\”)
.如果真结束
写注册项 (#根类, “.” + 关联文件类型 + “\”, 关联文件类型 + “file”)
写注册项 (#根类, 关联文件类型 + “file\”, 关联文件类型)
写注册项 (#根类, 关联文件类型 + “file\DefaultIcon\”, 关联文件图标 + “,0”)
写注册项 (#根类, 关联文件类型 + “file\shell\open\command\”, 关联应用程序 + “ ” + #引号 + “%1” + #引号)

方法

_ 文件关联 (“D:\vdsnm.exe”, “rack”, “D:\vdsnm.exe”,假)

版权声明:本站所有文章和资源使用BY-NC-SA协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言怎么写关联文件源码!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址