• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~! QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.

任意档次宠物生成工具 Ver 2.1 (易语言源码)

易语言 奇跡の海 1个月前 (01-07) 16次浏览 0个评论 扫描二维码

简介

任意档次宠物生成工具 Ver 2.1 (易语言源码)
任意档次宠物生成工具

代码

窗口程序集1

.版本 2
.支持库 iext
.支持库 mysql

.程序集 窗口程序集1
.程序集变量 提示框计时, 整数型
.程序集变量 角色信息, 文本型, , "2,2"
.程序集变量 被选角色, 文本型
.程序集变量 宠物资料, 文本型, , "0"
.程序集变量 宠物PPT, 整数型

.子程序 _主窗口_创建完毕

置外形图片 (#主窗口背景, #黑色)
提示消息 (“Power By Leaf.”, #紫色)

.子程序 _关闭_被单击

销毁 ()

.子程序 _标题栏_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

主窗口.发送信息 (161, 2, 0)

.子程序 _提示文字_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

提示框计时 = 0
提示框时钟.时钟周期 = 0
连续赋值 (假, 提示框体.可视, 提示文字.可视, 提示图标.可视, 分组框1.禁止, 分组框2.禁止, 分组框3.禁止)


.子程序 宠物BASE
.参数 BASE数组, 文本型, 数组
.参数 宠物ID, 整数型
.局部变量 i, 整数型
.局部变量 o, 整数型

重定义数组 (BASE数组, 假, 0)
.计次循环首 (取数组下标 (宠物信息, 1), i)
    .如果真 (到整数 (宠物信息 [i] [2]) = 宠物ID)
        .计次循环首 (46, o)
            加入成员 (BASE数组, 宠物信息 [i] [o])
        .计次循环尾 ()
        跳出循环 ()
    .如果真结束

.计次循环尾 ()

.子程序 获取栏位, 文本型
.参数 帐号, 文本型
.参数 序号, 文本型
.局部变量 记录集, 整数型
.局部变量 记录集行数, 整数型
.局部变量 字段值, 文本型
.局部变量 行, 整数型
.局部变量 玩家宠物信息, 整数型, , "5"

执行SQL语句 (MySql句柄, “SELECT * FROM tbl_pet WHERE `CdKey`='” + 帐号 + “' AND RegistNumber=” + 序号)
记录集 = 取记录集 (MySql句柄)
记录集行数 = 取记录集行数 (记录集)
.计次循环首 (5, 行)
    玩家宠物信息 [行] = 0
.计次循环尾 ()
.计次循环首 (记录集行数, 行)
    读字段值 (记录集, 97, 字段值)
    .如果真 (到整数 (字段值) = 0)
        读字段值 (记录集, 100, 字段值)
        玩家宠物信息 [到整数 (字段值) + 1] = 1
    .如果真结束
    到下一行 (记录集)
.计次循环尾 ()
.计次循环首 (5, 行)
    .如果真 (玩家宠物信息 [行] = 0)
        返回 (到文本 (行 - 1))
    .如果真结束

.计次循环尾 ()
返回 (“-1”)

.子程序 检查在线, 逻辑型
.参数 帐号, 文本型

.如果 (取记录集行数 (查找记录 (MySql句柄, “tbl_lock”, “*”, “CdKey='” + 帐号 + “'”, “CdKey DESC”)) > 0)
    信息框 (“账户在线”, #错误图标, “错误”)
    返回 (真)
.否则
    返回 (假)
.如果结束


.子程序 时间到戳, 整数型
.参数 转换时间, 日期时间型

返回 (取时间间隔 (转换时间, 到时间 (“1970-01-01 08:00:00”), #秒))

.子程序 提示消息
.参数 提示内容, 文本型, 可空
.参数 提示颜色, 整数型, 可空

处理事件 ()
.如果真 (是否为空 (提示内容))
    提示内容 = “请稍后...”
.如果真结束
.如果真 (是否为空 (提示颜色))
    提示颜色 = #红色
.如果真结束
提示文字.文本颜色 = 提示颜色
提示文字.标题 = 提示内容
提示框计时 = 0
提示文字.获取焦点 ()
连续赋值 (真, 提示框体.可视, 提示文字.可视, 提示图标.可视, 分组框1.禁止, 分组框2.禁止, 分组框3.禁止)
提示框时钟.时钟周期 = 1000

.子程序 _提示框时钟_周期事件

.如果 (提示框计时 > 0)
    提示框计时 = 0
    提示框时钟.时钟周期 = 0
    连续赋值 (假, 提示框体.可视, 提示文字.可视, 提示图标.可视, 分组框1.禁止, 分组框2.禁止, 分组框3.禁止)
.否则
    提示框计时 = 提示框计时 + 1
.如果结束


.子程序 _帐号_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型
.局部变量 记录集, 整数型
.局部变量 记录集行数, 整数型
.局部变量 字段值, 文本型, , "3"
.局部变量 循环变量, 整数型

角色名.标题 = “尚未选择”
帐号图示.正常图片 = #放大镜
连续赋值 (真, 左侧.禁止, 右侧.禁止)
连续赋值 (假, 左侧.选中, 右侧.选中)
.如果真 (键代码 = #回车键)
    提示消息 ()
    重定义数组 (角色信息, 假, 2, 2)
    .如果真 (取文本长度 (帐号.内容) > 0)
        帐号图示.正常图片 = #问号
        ' 执行SQL语句 (MySql句柄, “SELECT `DataPlaceNumber`,`RegistNumber`,`Name` FROM tbl_character WHERE `CdKey`='” + 帐号.内容 + “' ORDER BY `DataPlaceNumber` ASC”)
        执行SQL语句 (MySql句柄, “SELECT `DataPlaceNumber`,`RegistNumber`,`Name` FROM tbl_character WHERE `CdKey`='” + 帐号.内容 + “' ORDER BY `DataPlaceNumber` ASC”)
        记录集 = 取记录集 (MySql句柄)
        记录集行数 = 取记录集行数 (记录集)
        帐号图示.正常图片 = #叉叉
        .如果 (记录集行数 > 0)
            帐号图示.正常图片 = #对勾
            .如果 (记录集行数 = 1)
                读字段值 (记录集, 0, 字段值 [1])
                读字段值 (记录集, 1, 字段值 [2])
                读字段值 (记录集, 2, 字段值 [3])
                .如果 (到整数 (字段值 [1]) = 0)
                    左侧.禁止 = 假
                .否则
                    右侧.禁止 = 假
                .如果结束
                角色信息 [到整数 (字段值 [1]) + 1] [1] = 字段值 [2]
                角色信息 [到整数 (字段值 [1]) + 1] [2] = 字段值 [3]
            .否则
                .如果 (记录集行数 = 2)
                    .计次循环首 (记录集行数, 循环变量)
                        读字段值 (记录集, 0, 字段值 [1])
                        读字段值 (记录集, 1, 字段值 [2])
                        读字段值 (记录集, 2, 字段值 [3])
                        角色信息 [到整数 (字段值 [1]) + 1] [1] = 字段值 [2]
                        角色信息 [到整数 (字段值 [1]) + 1] [2] = 字段值 [3]
                        到下一行 (记录集)
                    .计次循环尾 ()
                    提示消息 (“搜索成功”, #墨绿)
                    连续赋值 (假, 左侧.禁止, 右侧.禁止)
                .否则
                    帐号图示.正常图片 = #叉叉
                    连续赋值 (真, 左侧.禁止, 右侧.禁止)
                    提示消息 (“数据异常”)
                .如果结束

            .如果结束

        .否则
            提示消息 (“无此账户”)
        .如果结束


    .如果真结束
    返回 (假)
.如果真结束


.子程序 _宠编号_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型

宠物名.标题 = “尚未选择”
连续赋值 (真, 掉档_体力.禁止, 掉档_力量.禁止, 掉档_强度.禁止, 掉档_速度.禁止, 掉档_魔法.禁止, 分配按钮.禁止)
.如果真 (键代码 = #减号键)
    返回 (假)
.如果真结束
.如果真 (键代码 = #回车键)
    宠物验证.获取焦点 ()
    _宠物验证_被单击 ()
    返回 (假)
.如果真结束


.子程序 _左侧_被单击

.如果 (取文本长度 (角色信息 [1] [2]) > 0)
    角色名.标题 = 角色信息 [1] [2]
    被选角色 = 角色信息 [1] [1]
.否则
    角色名.标题 = “无角色”
.如果结束


.子程序 _右侧_被单击

.如果 (取文本长度 (角色信息 [2] [2]) > 0)
    角色名.标题 = 角色信息 [2] [2]
    被选角色 = 角色信息 [2] [1]
.否则
    角色名.标题 = “无角色”
.如果结束


.子程序 _宠物验证_被单击

宠物验证.获取焦点 ()
.如果真 (取文本长度 (宠编号.内容) > 0 且 到整数 (宠编号.内容) > 0)
    宠物BASE (宠物资料, 到整数 (宠编号.内容))
    .如果 (取数组成员数 (宠物资料) > 40)
        宠物PPT = 到整数 (宠物资料 [6]) × 64 × 64 × 64 × 64 + 到整数 (宠物资料 [7]) × 64 × 64 × 64 + 到整数 (宠物资料 [8]) × 64 × 64 + 到整数 (宠物资料 [9]) × 64 + 到整数 (宠物资料 [10])
        宠物名.文本颜色 = #深灰
        宠物名.标题 = 宠物资料 [1]
        连续赋值 (假, 掉档_体力.禁止, 掉档_力量.禁止, 掉档_强度.禁止, 掉档_速度.禁止, 掉档_魔法.禁止, 分配按钮.禁止)
    .否则
        宠物名.文本颜色 = #红色
        宠物名.标题 = “无数据”
        连续赋值 (真, 掉档_体力.禁止, 掉档_力量.禁止, 掉档_强度.禁止, 掉档_速度.禁止, 掉档_魔法.禁止, 分配按钮.禁止)
    .如果结束

.如果真结束


.子程序 _分配按钮_被单击
.局部变量 SQL语句, 文本型
.局部变量 记录集, 整数型
.局部变量 记录集行数, 整数型
.局部变量 分配栏位, 文本型
.局部变量 分配宠物BP, 文本型, , "5"
.局部变量 分配宠物PPT, 整数型
.局部变量 i, 整数型

.如果真 (取文本长度 (被选角色) < 1 或 角色名.标题 = “尚未选择” 或 角色名.标题 = “无角色”)
    提示消息 (“请选择角色”)
    返回 ()
.如果真结束
.如果真 (掉档_体力.现行选中项 + 掉档_力量.现行选中项 + 掉档_强度.现行选中项 + 掉档_速度.现行选中项 + 掉档_魔法.现行选中项 > 20)
    提示消息 (“掉档总数 > 20”)
    返回 ()
.如果真结束
.如果真 (检查在线 (帐号.内容))
    提示消息 (“账户在线”)
    返回 ()
.如果真结束
分配栏位 = 获取栏位 (帐号.内容, 被选角色)
.如果真 (到整数 (分配栏位) = -1)
    提示消息 (“角色宠物栏不足”)
    返回 ()
.如果真结束
分配宠物PPT = 宠物PPT - 掉档_体力.现行选中项 × 64 × 64 × 64 × 64 - 掉档_力量.现行选中项 × 64 × 64 × 64 - 掉档_强度.现行选中项 × 64 × 64 - 掉档_速度.现行选中项 × 64 - 掉档_魔法.现行选中项
.如果真 (分配宠物PPT < 0)
    分配宠物PPT = 0
.如果真结束
分配宠物PPT = 分配宠物PPT + 34087042
分配宠物BP [1] = 到文本 (到整数 (宠物资料 [6]) × 20 + 80 - 掉档_体力.现行选中项 × 20)
分配宠物BP [2] = 到文本 (到整数 (宠物资料 [7]) × 20 + 80 - 掉档_力量.现行选中项 × 20)
分配宠物BP [3] = 到文本 (到整数 (宠物资料 [8]) × 20 + 80 - 掉档_强度.现行选中项 × 20)
分配宠物BP [4] = 到文本 (到整数 (宠物资料 [9]) × 20 + 80 - 掉档_速度.现行选中项 × 20)
分配宠物BP [5] = 到文本 (到整数 (宠物资料 [10]) × 20 + 80 - 掉档_魔法.现行选中项 × 20)
.计次循环首 (10, i)
    .如果真 (宠物资料 [i + 36] = “”)
        宠物资料 [i + 36] = “-1”
    .如果真结束

.计次循环尾 ()
SQL语句 = “INSERT INTO tbl_pet values (3,'” + 宠物资料 [31] + “','” + 宠物资料 [31] + “',0,0,0,0,0,1,1,1,'” + 分配宠物BP [1] + “','” + 分配宠物BP [2] + “','” + 分配宠物BP [3] + “','” + 分配宠物BP [4] + “','” + 分配宠物BP [5] + “',0,'” + 宠物资料 [5] + “','” + 宠物资料 [16] + “','” + 宠物资料 [17] + “','” + 宠物资料 [18] + “','” + 宠物资料 [19] + “','” + 宠物资料 [20] + “','” + 宠物资料 [21] + “','” + 宠物资料 [22] + “','” + 宠物资料 [23] + “','” + 宠物资料 [24] + “','” + 宠物资料 [25] + “','” + 宠物资料 [28] + “','” + 宠物资料 [29] + “','” + 宠物资料 [14] + “','” + 宠物资料 [15] + “',0,0,0,0,0,” + 到文本 (时间到戳 (取现行时间 ())) + “,0,0,0,0,0,0,0,” + 到文本 (分配宠物PPT) + “,0,0,0,0,0,'” + 宠物资料 [30] + “',0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,'” + 宠物资料 [2] + “',0,0,0,'” + 宠物资料 [37] + “','” + 宠物资料 [38] + “','” + 宠物资料 [39] + “','” + 宠物资料 [40] + “','” + 宠物资料 [41] + “','” + 宠物资料 [42] + “','” + 宠物资料 [43] + “','” + 宠物资料 [44] + “','” + 宠物资料 [45] + “','” + 宠物资料 [46] + “',0,0,0,0,0,0,0,0,0,0,'” + 宠物资料 [1] + “','','” + 帐号.内容 + “','” + 帐号.内容 + “','” + 角色名.标题 + “',0,'” + 帐号.内容 + “','” + 被选角色 + “',” + 分配栏位 + “,0)”
.如果 (执行SQL语句 (MySql句柄, SQL语句))
    提示消息 (“分配宠物成功”, #墨绿)
.否则
    提示消息 (“分配宠物失败”)
.如果结束

窗口程序集2

.版本 2
.支持库 iext
.支持库 mysql

.程序集 窗口程序集2

.子程序 __启动窗口_创建完毕

置外形图片 (#启动背景, #黑色)
地址.内容 = 读配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “地址”, “127.0.0.1”)
端口.内容 = 读配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “端口”, “3306”)
账户.内容 = 读配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “账户”, “root”)
密码.内容 = 读配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “密码”, “”)
库名.内容 = 读配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “库名”, “rogue”)

.子程序 __启动窗口_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

_启动窗口.发送信息 (161, 2, 0)

.子程序 _取消按钮_被单击

销毁 ()

.子程序 _连接按钮_被单击
.局部变量 文件内容, 文本型
.局部变量 分割文件, 文本型, , "0"
.局部变量 分割行, 文本型, , "0"
.局部变量 循环变量, 整数型
.局部变量 循环变量2, 整数型

提示标签.文本颜色 = #灰色
提示标签.标题 = “连接中..”
MySql句柄 = 连接MySql (地址.内容, 账户.内容, 密码.内容, 库名.内容, 到整数 (端口.内容))
.如果 (MySql句柄 = 0)
    提示标签.文本颜色 = #红色
    提示标签.标题 = “连接失败”
.否则
    .如果真 (取反 (文件是否存在 (取运行目录 () + “\enemybase.txt”)))
        信息框 (“请将魔力服务端内的” + #换行符 + “enemybase.txt 文件” + #换行符 + “放置于程序同目录!”, #错误图标, “缺少文件”)
        提示标签.文本颜色 = #紫色
        提示标签.标题 = “缺少文件”
        断开MySql (MySql句柄)
        返回 ()
    .如果真结束
    文件内容 = 读入文本 (打开文件 (取运行目录 () + “\enemybase.txt”, , ), )
    分割文件 = 分割文本 (文件内容, #换行符, )
    重定义数组 (宠物信息, 假, 取数组成员数 (分割文件), 46)
    .计次循环首 (取数组成员数 (分割文件), 循环变量)
        分割行 = 分割文本 (分割文件 [循环变量], 字符 (9), )
        .如果真 (取数组成员数 (分割行) > 10)
            .计次循环首 (取数组成员数 (分割行), 循环变量2)
                宠物信息 [循环变量] [循环变量2] = 分割行 [循环变量2]
            .计次循环尾 ()
        .如果真结束

    .计次循环尾 ()
    写配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “地址”, 地址.内容)
    写配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “端口”, 端口.内容)
    写配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “账户”, 账户.内容)
    写配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “密码”, 密码.内容)
    写配置项 (取运行目录 () + “\Config.ini”, “数据库配置”, “库名”, 库名.内容)
    载入 (主窗口, , 假)
    销毁 ()
.如果结束

源码下载

下载地址
密码:nt9a


版权声明:本站所有文章和资源使用BY-NC-SA协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->任意档次宠物生成工具 Ver 2.1 (易语言源码)!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址