• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言源码-易语言获取盘符并且搜索已经找到的盘符内的文件

易语言 奇跡の海 3周前 (06-06) 40次浏览 已收录 0个评论 扫描二维码

易语言源码-易语言获取盘符并且搜索已经找到的盘符内的文件
易语言获取盘符并且搜索已经找到的盘符内的文件

.版本 2
.支持库 eAPI
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 找到, 逻辑型

.子程序 _按钮1_被单击
.局部变量 盘符, 文本型, , "0"
.局部变量 n1, 整数型

盘符 = 取驱动器列表 ()
.计次循环首 (取数组成员数 (盘符), n1)
    文件搜索 (盘符 [n1])
.计次循环尾 ()
标签1.标题 = “搜索完毕!共搜索到 ” + 到文本 (列表框1.取项目数 ()) + “ 个文件”

.子程序 文件搜索
.参数 文件目录, 文本型
.局部变量 文件, 文本型

.如果真 (找到 = 真)
    返回 ()
.如果真结束
.如果真 (取文本右边 (文件目录, 1) ≠ “\”)
    文件目录 = 文件目录 + “\”
.如果真结束
文件 = 寻找文件 (文件目录 + “*.exe”, )
.判断循环首 (文件 ≠ “”)
    处理事件 ()
    标签1.标题 = 文件目录 + 文件
    调试输出 (文件)
    .如果真 (到小写 (文件) = 到小写 (“qq.exe”))
        列表框1.加入项目 (文件目录 + 文件, )
        找到 = 真
        跳出循环 ()
    .如果真结束
    文件 = 寻找文件 (, )
.判断循环尾 ()
文件 = 寻找文件 (文件目录 + “*.*”, #子目录)
.判断循环首 (文件 ≠ “”)
    .如果真 (取文本左边 (文件, 1) ≠ “.”)
        文件搜索 (文件目录 + 文件)
    .如果真结束
    文件 = 寻找文件 (, #子目录)
.判断循环尾 ()
取驱动器列表 ()


版权声明:本站所有文章和资源使用CC BY-NC-SA 4.0协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言源码-易语言获取盘符并且搜索已经找到的盘符内的文件!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址