• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言源码-遍历磁盘目录,寻找文件并删除

易语言 奇跡の海 3周前 (06-07) 26次浏览 已收录 0个评论 扫描二维码

易语言源码-遍历磁盘目录,寻找文件并删除
遍历磁盘目录,寻找文件并删除

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕



.子程序 _按钮1_被单击

' 文件_枚举1 (“c:”, “*.*”, &子程序1)
文件_搜索_深度 (“d:”, &子程序1, “*.vbs”, 2)
分割子程序1 ()

.子程序 子程序1
.参数 目录, 文本型

' 调试输出 (目录)
编辑框1.内容 = 目录

.子程序 分割子程序1
.局部变量 行, 文本型, , "0"
.局部变量 分割, 文本型, , "0"
.局部变量 计次, 整数型
.局部变量 你想要的文本, 文本型
.局部变量 数组位置, 整数型

行 = 分割文本 (编辑框1.内容, “\”, )
.计次循环首 (取数组成员数 (行), 计次)
    .如果真 (寻找文本 (行 [计次], “vbs”, , 假) ≠ -1)
        ' 分割 = 分割文本 (行 [计次], “ ”, )
        数组位置 = 计次
        你想要的文本 = 行 [数组位置]
        调试输出 (你想要的文本)
    .如果真结束

.计次循环尾 ()
编辑框2.内容 = 文本_替换 (编辑框1.内容, , , , 你想要的文本, “”)

.子程序 置属性程序
.局部变量 文件名, 文本型
.局部变量 子文件夹, 文本型

文件名 = 寻找文件 (“d:\xxxx\*.*”, )
.如果真 (文件名 ≠ “”)
    置文件属性 (“d:\xxxx\” + 文件名, #存档文件)
.如果真结束
.判断循环首 (文件名 ≠ “”)
    文件名 = 寻找文件 (, )
    .如果真 (文件名 ≠ “”)
        置文件属性 (“d:\xxxx\” + 文件名, #存档文件)
    .如果真结束

.判断循环尾 ()
子文件夹 = 寻找文件 (“d:\xxxx\*.*”, #子目录)
调试输出 (子文件夹)
.如果真 (子文件夹 ≠ “” 且 子文件夹 ≠ “.”)
    置文件属性 (“d:\xxxx\” + 子文件夹, #存档文件)
.如果真结束
.判断循环首 (子文件夹 ≠ “”)
    子文件夹 = 寻找文件 (, #子目录)
    .如果真 (子文件夹 ≠ “” 且 子文件夹 ≠ “.”)
        置文件属性 (“d:\xxxx\” + 子文件夹, #存档文件)
    .如果真结束

.判断循环尾 ()
延迟 (100)
删除目录 (“d:\xxxx”)

.子程序 _按钮2_被单击

置属性程序 ()


版权声明:本站所有文章和资源使用CC BY-NC-SA 4.0协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言源码-遍历磁盘目录,寻找文件并删除!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址