• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言 API模拟鼠标滚轮上下滚动

易语言 奇跡の海 2周前 (07-10) 82次浏览 已收录 0个评论 扫描二维码

简介

易语言 API模拟鼠标滚轮上下滚动
易语言 模拟鼠标滚轮上下滚动,120为距离,正为上 负为下mouse_event (#MOUSEEVENTF_WHEEL, 0, 0, -120, 0)

源码

.版本 2

.程序集 窗口程序集1
.程序集变量 sss, 整数型

.子程序 _按钮1_被单击

编辑框1.获取焦点 ()
mouse_event (#MOUSEEVENTF_WHEEL, 0, 0, -120, 0)



.子程序 _按钮2_被单击

编辑框1.获取焦点 ()
mouse_event (#MOUSEEVENTF_WHEEL, 0, 0, 120, 0)


DLL命令

.版本 2

.DLL命令 mouse_event, , "user32", "mouse_event", , 模拟一次鼠标事件
    .参数 dwFlags, 整数型, , 下述标志的一个组合;MOUSEEVENTF_ABSOLUTE:dx和dy指定鼠标坐标系统中的一个绝对位置。在鼠标坐标系统中,屏幕在水平和垂直方向上均匀分割成65535×65535个单元;MOUSEEVENTF_MOVE:移动鼠标;MOUSEEVENTF_LEFTDOWN:模拟鼠标左键按下;MOUSEEVENTF_LEFTUP:模拟鼠标左键抬起;MOUSEEVENTF_RIGHTDOWN:模拟鼠标右键按下;MOUSEEVENTF_RIGHTUP:模拟鼠标右键按下;MOUSEEVENTF_MIDDLEDOWN:模拟鼠标中键按下;MOUSEEVENTF_MIDDLEUP:模拟鼠标中键按下
    .参数 dx, 整数型, , 根据是否指定了MOUSEEVENTF_ABSOLUTE标志,指定水平方向的绝对位置或相对运动
    .参数 dy, 整数型, , 根据是否指定了MOUSEEVENTF_ABSOLUTE标志,指定垂直方向的绝对位置或相对运动
    .参数 cButtons, 整数型, , 未使用
    .参数 dwExtraInfo, 整数型, , 通常未用的一个值。用GetMessageExtraInfo函数可取得这个值。可用的值取决于特定的驱动程序;


版权声明:本站所有文章和资源使用CC BY-NC-SA 4.0协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言 API模拟鼠标滚轮上下滚动!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址