• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言 读写配置项(ini配置文件)源码

易语言 奇跡の海 3个月前 (07-12) 260次浏览 已收录 0个评论 扫描二维码

简介

易语言 读写配置项(ini配置文件)源码
易语言 读写配置项(ini配置文件)源码

源码

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 账号, 文本型
.局部变量 密码, 文本型
.局部变量 仓库, 文本型
.局部变量 i, 整数型
.局部变量 a, 整数型
.局部变量 b, 整数型

.计次循环首 (超级列表框1.取表项数 (), i)
    a = 超级列表框1.现行选中项
    b = 超级列表框1.取表项数 ()

    写配置项 (取运行目录 () + “\配置.ini”, “账号数量”, “数量”, 到文本 (b))

    写配置项 (取运行目录 () + “\配置.ini”, “现行选中项”, “选中”, 到文本 (a))
    .计次循环首 (超级列表框1.取表项数 (), i)
        写配置项 (取运行目录 () + “\配置.ini”, “账号”, 到文本 (i), 超级列表框1.取标题 (i - 1, 1))
    .计次循环尾 ()
    .计次循环首 (超级列表框1.取表项数 (), i)
        写配置项 (取运行目录 () + “\配置.ini”, “密码”, 到文本 (i), 超级列表框1.取标题 (i - 1, 2))
    .计次循环尾 ()
    .计次循环首 (超级列表框1.取表项数 (), i)
        写配置项 (取运行目录 () + “\配置.ini”, “仓库”, 到文本 (i), 超级列表框1.取标题 (i - 1, 3))
    .计次循环尾 ()


.计次循环尾 ()


.子程序 _按钮2_被单击

' 求大神帮忙写下读配置项的代码,

.子程序 __启动窗口_创建完毕



.子程序 超级列表框_写配置项, , 公开
.参数 组件, 超级列表框
.参数 配置文件名, 文本型
.参数 只写出数据, 逻辑型, 可空
.局部变量 i, 整数型
.局部变量 x, 整数型

写配置项 (配置文件名, “Rect”, “Rows”, 到文本 (组件.取表项数 ()))  ' 当前行数
写配置项 (配置文件名, “Rect”, “Cols”, 到文本 (组件.取列数 ()))  ' 当前列数
.如果真 (只写出数据 = 假)
    写配置项 (配置文件名, “Setting”, “Width”, 到文本 (组件.左边))  ' 左边
    写配置项 (配置文件名, “Setting”, “Height”, 到文本 (组件.顶边))  ' 顶边
    写配置项 (配置文件名, “Setting”, “Width”, 到文本 (组件.宽度))  ' 宽度
    写配置项 (配置文件名, “Setting”, “Height”, 到文本 (组件.高度))  ' 高度
    写配置项 (配置文件名, “Setting”, “Border”, 到文本 (组件.边框))  ' 高度
    写配置项 (配置文件名, “Setting”, “Visible”, 到文本 (组件.可视))  ' 可视
    写配置项 (配置文件名, “Setting”, “TextColor”, 到文本 (组件.文本颜色))  ' 文本颜色
    写配置项 (配置文件名, “Setting”, “TextBackColor”, 到文本 (组件.文本背景色))  ' 文本背景
    写配置项 (配置文件名, “Setting”, “BackgroundColor”, 到文本 (组件.背景颜色))  ' 背景颜色
    .如果 (组件.无表头)
        写配置项 (配置文件名, “Setting”, “NoHead”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “NoHead”, 到文本 (0))
    .如果结束
    .如果 (组件.整行选择)
        写配置项 (配置文件名, “Setting”, “SelectRow”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “SelectRow”, 到文本 (0))
    .如果结束
    .如果 (组件.表头可单击)
        写配置项 (配置文件名, “Setting”, “ClickHead”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “ClickHead”, 到文本 (0))
    .如果结束
    .如果 (组件.显示表格线)
        写配置项 (配置文件名, “Setting”, “ShowListBorder”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “ShowListBorder”, 到文本 (0))
    .如果结束
    .如果 (组件.表列可拖动)
        写配置项 (配置文件名, “Setting”, “DragHead”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “DragHead”, 到文本 (0))
    .如果结束
    .如果 (组件.允许编辑)
        写配置项 (配置文件名, “Setting”, “EditAllow”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “EditAllow”, 到文本 (0))
    .如果结束

    写配置项 (配置文件名, “Setting”, “SortAllow”, 到文本 (组件.排序方式))
    .如果 (组件.是否有检查框)
        写配置项 (配置文件名, “Setting”, “CheckBox”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “CheckBox”, 到文本 (0))
    .如果结束
    .如果 (组件.平面滚动条)
        写配置项 (配置文件名, “Setting”, “FlatScrollBar”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “FlatScrollBar”, 到文本 (0))
    .如果结束
    .如果 (组件.单一选择)
        写配置项 (配置文件名, “Setting”, “SelectOnly”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “SelectOnly”, 到文本 (0))
    .如果结束

    写配置项 (配置文件名, “Setting”, “SelectNow”, 到文本 (组件.现行选中项))
    .如果 (组件.始终显示选择项)
        写配置项 (配置文件名, “Setting”, “ShowSelectAlways”, 到文本 (1))
    .否则
        写配置项 (配置文件名, “Setting”, “ShowSelectAlways”, 到文本 (0))
    .如果结束

.如果真结束
.计次循环首 (组件.取列数 (), x)
    写配置项 (配置文件名, “Cols”, “Width” + 到文本 (x - 1), 到文本 (组件.取列宽 (x - 1)))  ' 每列宽度
    写配置项 (配置文件名, “Cols”, “Name” + 到文本 (x - 1), 组件.取列标题 (x - 1))  ' 每列标题
.计次循环尾 ()
.计次循环首 (组件.取表项数 (), i)
    .计次循环首 (组件.取列数 (), x)
        写配置项 (配置文件名, 到文本 (i - 1), 到文本 (x - 1), 组件.取标题 (i - 1, x - 1))  ' 列表单元数据
    .计次循环尾 ()
.计次循环尾 ()

.子程序 超级列表框_读配置项, , 公开
.参数 组件, 超级列表框
.参数 配置文件名, 文本型
.参数 只读入数据, 逻辑型, 可空
.局部变量 i, 整数型
.局部变量 x, 整数型

.判断循环首 (组件.取列数 () < 到整数 (读配置项 (配置文件名, “Rect”, “Cols”, 到文本 (0))))
    组件.插入列 (, , , , , )
.判断循环尾 ()
.如果真 (只读入数据 = 假)
    .计次循环首 (到整数 (读配置项 (配置文件名, “Rect”, “Cols”, 到文本 (0))), x)
        组件.置列宽 (x - 1, 到整数 (读配置项 (配置文件名, “Cols”, “Width” + 到文本 (x - 1), “”)))  ' 每列宽度
        组件.置列标题 (x - 1, 读配置项 (配置文件名, “Cols”, “Name” + 到文本 (x - 1), “”))  ' 每列名称
    .计次循环尾 ()
.如果真结束
.计次循环首 (到整数 (读配置项 (配置文件名, “Rect”, “Rows”, 到文本 (0))), i)
    组件.插入表项 (, 读配置项 (配置文件名, 到文本 (i - 1), 到文本 (0), “”), , , , )  ' 每行开头名称
    .计次循环首 (到整数 (读配置项 (配置文件名, “Rect”, “Cols”, 到文本 (0))), x)
        组件.置标题 (i - 1, x, 读配置项 (配置文件名, 到文本 (i - 1), 到文本 (x), “”))  ' 每行单元名称
    .计次循环尾 ()
.计次循环尾 ()

.子程序 _按钮3_被单击

超级列表框_写配置项 (超级列表框1, 取运行目录 () + “\a.ini”)

.子程序 _按钮4_被单击

超级列表框_读配置项 (超级列表框2, 取运行目录 () + “\a.ini”)


版权声明:本站所有文章和资源使用CC BY-NC-SA 4.0协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言 读写配置项(ini配置文件)源码!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址