• 欢迎访问奇跡の海网站,本站不上传任何资源,所有资源均来自于网络,欢迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下载资源为网络上收集整理而来,并且以计算机技术研究交流为目的,版权归原作者所有,仅供大家参考,学习,不存在任何商业目的与商业用途.
  • 本站系统镜像均来自于官方原版,ed2k可视为P2P下载链接。所有操作系统默认均为试用版,如有正版密钥可以有效激活,本站不提供任何激活和相关服务。

易语言中如何注册多个键盘热键(2)

易语言 奇跡の海 3个月前 (07-09) 180次浏览 已收录 0个评论 扫描二维码

方法

易语言中如何注册多个键盘热键(2)
新建一个标签1_反馈事件,然后导入代码

源码

.版本 2
.支持库 shellEx

.程序集 窗口程序集_启动窗口
.程序集变量 程_热键, 整数型, , "5"
.程序集变量 程_热键函数, 子程序指针, , "5"

.子程序 __启动窗口_创建完毕

程_热键 [1] = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), 1, #A键)  ' CTRL+A
程_热键函数 [1] = &子程序1
程_热键 [2] = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), 2, #B键)  ' SHIFT+B
程_热键函数 [2] = &子程序2
程_热键 [3] = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), 4, #C键)  ' ALT+C
程_热键函数 [3] = &子程序3
程_热键 [4] = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), 7, #A键)  ' CTRL+SHIFT+'ALT+A
程_热键函数 [4] = &子程序4


.子程序 _标签1_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.局部变量 次数, 整数型

' 循环,判断
.计次循环首 (取数组成员数 (程_热键), 次数)
    .如果真 (参数一 = 程_热键 [次数])
        执行子程序 (程_热键函数 [次数], )
    .如果真结束

.计次循环尾 ()

.子程序 子程序1, , , Ctrl+A

信息框 (“ctrl+A”, 0, , )

.子程序 子程序2, , , Shft+B

信息框 (“Shft+B”, 0, , )

.子程序 子程序3, , , Atl+C

信息框 (“Atl+C”, 0, , )

.子程序 子程序4, , , Ctrl+Shitf+Atl+A

信息框 (“Ctrl+Shitf+Atl+A”, 0, , )


版权声明:本站所有文章和资源使用CC BY-NC-SA 4.0协议授权发布 , 转载应当以相同方式注明文章来自“SeaOMC.COM->易语言中如何注册多个键盘热键(2)!在下边可以分享本文哦!
喜欢 (0)
[]
分享 (0)
奇跡の海
关于作者:
一个WordPress菜鸟!
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址